php低于7.2版本安装libsodium教程

微信支付通知回调需要使用AEAD_AES_256_GCM算法解密,这个算法需要开启libsodium拓展才能使用。

Windows下安装较为简单,可以参照下面的文档安装

https://blog.csdn.net/u010324331/article/details/82153067

Linux下安装也可照文档上操作

但有时候会报下面的错误

checking for libsodium files in default path... not found
configure: error: Please install libsodium - See https://github.com/jedisct1/libsodium
ERROR: `/var/tmp/libsodium/configure --with-php-config=/usr/bin/php-config' failed

这个时候需要先运行下面的语句安装linux发行版提供的libsodium。

CentOS 7:

yum install libsodium libsodium-devel

Ubuntu 18.04:

apt install libsodium libsodium-dev

之后再运行pecl 安装命令即可

 

   还没有人评论 到此为止 | 继续阅读 >>

发表评论

邮箱地址不会被公开。 必填项已用*标注